[concurrency-interest]some superficial comments

Paul Haahr paul@paulhaahr.com
Tue, 5 Feb 2002 13:42:08 -0800 (PST)

Having spent a little while catching up on Doug's aims page and the mail
to this list, I have little to add about the cancellation issues already
being discussed:  RunnableTask looks clean and sufficient to me, though
the resetCompletionStatus method bugs me.

But, I would like to throw my two cents in on some naming and syntactic
issues that are in the air:


  Rather than the name attempt, I'd much prefer to use tryAcquire.


  I hate the name HandOff.  Why not SynchronousQueue or RendezvousQueue?
  (Yes, I know calling it a queue might be misleading since it doesn't
  contain any elements, but I'd argue that, since it implements the
  Queue interface, it's a queue.)


  I like the name BrokenBarrierException -- it's clear.


  I agree with Mark that there doesn't appear to be a good reason to
  make Callable take an argument:  this should typically just be a inner
  class closure, like Runnable.


  These attributes objects seem like conceptual overhead.  I'd rather
  just see the predicates as methods in the Lock objects.