[concurrency-interest] Why not J2SE 5?

David Holmes dholmes@dltech.com.au
Mon, 6 Dec 2004 23:59:28 +1000


> I wish jdk1.5 had the option of compiling into at least jdk1.4 byte
> code.  So even though production systems still need to stay with 1.4,
> development can start moving to 1.5.

It does! Use the -source and -target options on javac eg:

javac -target 1.4 -source 1.4 Foo.java

David Holmes