[concurrency-interest] Why not J2SE 5?

Joe Bowbeer jozart@blarg.net
Mon, 6 Dec 2004 06:03:33 -0800

I'm running my J2ME development tools in Sun's 1.5 VM and I've had to make a 
few changes to some of the Ant build scripts and Ant extensions (tasks); 
otherwise, javac 1.5 balks with: "target release 1.x conflicts with default 
source release 1.5".

The solution is to pass -source and -target on the command line:

javac -source 1.2 -target 1.2 ...

I wish there were a way to do this without having to change all the javac 
command lines.

----- Original Message ----- 
From: "Hanson Char" <hanson.char@gmail.com>
To: <concurrency-interest@altair.cs.oswego.edu>
Sent: Monday, December 06, 2004 5:45 AM
Subject: Re: [concurrency-interest] Why not J2SE 5?

I wish jdk1.5 had the option of compiling into at least jdk1.4 byte
code.  So even though production systems still need to stay with 1.4,
development can start moving to 1.5.