[concurrency-interest] Why not J2SE 5?

Kris Schneider kris@dotech.com
Mon, 6 Dec 2004 10:15:19 -0500


That should actually result in an error because of a conflict with the default
source release: 1.5. If you want to cross-compile, I'd suggest using something
like:

javac -source 1.4 -target 1.4 -bootclasspath $JDK142/jre/lib/rt.jar -extdirs
$JDK142/jre/lib/ext -endorseddirs $JDK142/jre/lib/endorsed ...

Which I guess is nice if you want to make use of the J2SE 5.0 *compiler*, but it
won't allow developers to make use of new language features and classes while
magically running on a 1.4 JVM.

Quoting Michael Ogg <ogg@valaran.com>:

> but it does:
> javac -target x.y
> will do just what you want.
> 
> Michael
> 
> Hanson Char wrote:
> 
> > I wish jdk1.5 had the option of compiling into at least jdk1.4 byte
> > code.  So even though production systems still need to stay with 1.4,
> > development can start moving to 1.5.
> > 
> > Hanson
> > 
> > 
> > On Mon, 6 Dec 2004 14:17:20 +0100, Paul Wagland <paul@kungfoocoder.org>
> wrote:
> > 
> >>Hi Doug,
> >>
> >>
> >>
> >>On Dec 6, 2004, at 13:56, Doug Lea wrote:
> >>
> >>
> >>>I'm starting to wonder why there's so much resistance out there to
> >>>changing from 1.x to J2SE5 (1.5). Having seen how obsessed the Sun
> >>>J2SE5 release managers and engineers were with back-compatibility, and
> >>>the huge numbers of regression tests run, and the very large number of
> >>>bug-fixes and performance improvements in J2SE5, I honestly don't know
> >>>of a good technical reason not to switch over to it, even (or
> >>>especially?) if people don't need new functionality. I suppose some of
> >>>it might be just be fear of any x.0 release (to be addressed soon, I
> >>>think, with the first "underscore" release, "1.5_01" or somesuch
> >>>name). And maybe it takes time to install/deploy new JVMs across all
> >>>machines etc. But is there some more fundamental reason that I'm
> >>>overlooking?
> >>
> >>
> >>Yes, there is. (unfortunately)
> >>
> >>One of the reasons that the company that I am currently working for is
> >>using Java 1.5, is because it is cross-platform. At the moment, the
> >>list of supported platforms for 1.5 is:
> >>Windows
> >>Linux
> >>Solaris
> >>
> >>A partial list of platforms that currently have 1.4:
> >>Apple OSX
> >>AIX
> >>z/OS
> >>HP/UX
> >>
> >>Note that those last three are required platforms for support (for us
> >>at least).
> >>
> >>Add to that, we need to run inside of an application server, last I
> >>checked, half of those were still based around Java 1.3
> >>
> >>Your mileage may vary, but for many people, that cross platform ability
> >>really is important, for the reasons stated above, we will be staying
> >>with Java 1.3 as our target platform, and trying to ensure that we also
> >>work with newer JDKs where available. Ultimately, for us, that means we
> >>will be trying the backport of JSR166, and if that does not work, then
> >>we will continue on with our internally developed classes for this
> >>functionality.
> >>
> >>On the other hand, we also have a client application, that only needs
> >>to run on windows and linux. That is allowed to use JDK 1.5.
> >>
> >>Food for thought,
> >>Cheers,
> >>Paul

-- 
Kris Schneider <mailto:kris@dotech.com>
D.O.Tech       <http://www.dotech.com/>