[concurrency-interest] Why not J2SE 5?

Hanson Char Hanson Char <hanson.char@gmail.com>
Tue, 7 Dec 2004 07:40:47 +1100


Using -source 1.4 doesn't make sense for development to move to 1.5 as
there is no or littel benefit of doing so.  What I wish is:

javac -target 1.4 -source 1.5 Foo.java

Hanson

On Mon, 6 Dec 2004 23:59:28 +1000, David Holmes <dholmes@dltech.com.au> wrote:
> > I wish jdk1.5 had the option of compiling into at least jdk1.4 byte
> > code.  So even though production systems still need to stay with 1.4,
> > development can start moving to 1.5.
> 
> It does! Use the -source and -target options on javac eg:
> 
> javac -target 1.4 -source 1.4 Foo.java
> 
> David Holmes
>