[concurrency-interest] Why not J2SE 5?

Alexey N. Solofnenko A.Solofnenko@mdl.com
Mon, 06 Dec 2004 14:07:12 -0800


Generics do not seem to require any JVM changes. This is one of the 
features I would want to use with JDK 1.4 too.

- Alexey.

David Holmes wrote:

>Hanson char wrote:
>  
>
>>Using -source 1.4 doesn't make sense for development to move to 1.5 as
>>there is no or littel benefit of doing so.  What I wish is:
>>
>>javac -target 1.4 -source 1.5 Foo.java
>>    
>>
>
>But most 1.5 features require 1.5 bytecode and or classes. So what would
>this gain you?
>
>I had assumed the intent was to have a single 5.0 development environment
>where you could build your 1.4 production system and at the same time
>experiment with 5.0 features seperately.
>
>David Holmes
>
>  
>