[concurrency-interest] Java 6 support in backport-concurrent

Greg Luck gluck at gregluck.com
Wed Aug 15 02:54:57 EDT 2007


Hi

There are lots of work arounds with varying degrees of ugliness. I  
think the best answer is for Dawid to just go ahead and release a  
Java 6 version of backport-concurrent.

On 15/08/2007, at 10:43 AM, Geoffrey Wiseman wrote:

> On 8/14/07, Greg Luck <gluck at gregluck.com> wrote:
> Ehcache uses backport-concurrent. The package names are backport  
> concurrent. I could change to JDK 1.5 j.u.c  by not using backport- 
> concurrent but then lose JDK1.4 support.
>
> If only there were a commons-concurrency, or a scf4j.  ;)
>
> That's unfortunate; if the number of classes that touch j.u.c is  
> small, you could isolate them to a thin layer and swap  
> implementations, but ... sounds like there's a deeper problem,  
> based on the other messages in this thread.
>
>   - Geoffrey
> -- 
> Geoffrey Wiseman

Regards

Greg Luck

web: http://gregluck.com
skype: gregrluck
yahoo: gregrluck
mobile: +61 408 061 622



-------------- next part --------------
An HTML attachment was scrubbed...
URL: /pipermail/attachments/20070815/498ab1e9/attachment-0001.html 


More information about the Concurrency-interest mailing list