[concurrency-interest] ForkJoinExecutor.invoke and ForkJoinTask.invoke
dl at cs.oswego.edu
Sat Dec 15 11:35:50 EST 2007
Tim Peierls wrote:
> I still think renaming FJTask.invoke() to forkJoin() would make this
> framework slightly easier to learn and reduce the potential for
> confusion with FJPool.invoke(task).
At first this name sounded too wrong to me -- shouldn't it be
forkAndJoin()? (precedent: atomic.getAndAdd()) Which itself
sounds odd. But just forkJoin() is somehow now starting to sound
OK to me, and you are right that it may forestall
some confusion. Any other opinions?
More information about the Concurrency-interest