[concurrency-interest] jsr166y.forkjoin API comments

David J. Biesack David.Biesack at sas.com
Mon Feb 4 15:27:48 EST 2008


> Doug wrote:
> > I wrote:
> > Rename CommonOps.compoundOp as CommonOps.compositeOp as per the well-known
> > Composite design pattern.

> Thanks; Sorry not to mention that it still in the set of likely changes.

On further thought, I think there is a better alternative: CommonOps.compose(a, b)

Also, andPredicate/orPredicate/notPredicate => and/or/not

-- 
David J. Biesack     SAS Institute Inc.
(919) 531-7771       SAS Campus Drive
http://www.sas.com   Cary, NC 27513



More information about the Concurrency-interest mailing list