[concurrency-interest] jsr166y.forkjoin API comments
dl at cs.oswego.edu
Mon Feb 4 20:39:58 EST 2008
David J. Biesack wrote:
>> Doug wrote:
>>> I wrote:
>>> Rename CommonOps.compoundOp as CommonOps.compositeOp as per the well-known
>>> Composite design pattern.
>> Thanks; Sorry not to mention that it still in the set of likely changes.
> On further thought, I think there is a better alternative: CommonOps.compose(a, b)
Yes, better; thanks!
(This why I generally sit a while on suggested name changes.
Usually when a name isn't very good, it takes a while to find best
alternative. I still plan to delay committing the current set of
suggestions a while longer. It's usually best to create one disruption
like this than a series of small ones that cause current users to
continually change their code.)
More information about the Concurrency-interest