[concurrency-interest] Ops type names

Doug Lea dl at cs.oswego.edu
Fri Jan 11 10:37:56 EST 2008

Courtesy of some suggestions by Josh Bloch, I'll be revamping
Ops type names in the near future. Plus incorporate new methods such as:
   WithMapping<V> withMapping(BinaryOp<T, U, V>, ParallelArray<U> other)
     (BinaryOp was "Combiner"; wildcards omitted here for clarity.)
which replaces the "combine" methods with more flexible operation
prefix support.

Sorry as always for the disruption to those of you using
this framework. Hopefully we are getting near the end of
these kinds of incompatible changes.


More information about the Concurrency-interest mailing list