[concurrency-interest] Ops type names

Gregg Wonderly gergg at cox.net
Tue Jan 15 11:06:17 EST 2008


Joshua Bloch wrote:
> Hi.  I understand your desire consistency.  That said, I was 
> inconsistent "with my eyes open."  Worse, I violated the norms in 
> mathematics.  When a mathematician speaks of a real-function, he speaks 
> of the range (result type), irrespective of the domain.  That said, when 
> it comes to designing APIs, I like to take the nice, short names for the 
> common cases, and I believe that the case of functions whose range and 
> domain types are the same will predominate (whether it's int-to-int, 
> long-to-long, or double-to-double).  So, I stole the nice names for the 
> common homogeneous function types.

Is there any useful readability gains from using more prepositional words like 
"with" or "on" instead of "Op", as in

onInt( 42 ).onInt( doubleToInt( 45.0 ) )

or

withInt( 42 ).withInt( doubleToInt( 45.0 ) )

since "to" is already prepositional in english?

Gregg Wonderly


More information about the Concurrency-interest mailing list