[concurrency-interest] Ops type names

David J. Biesack David.Biesack at sas.com
Tue Jan 15 15:38:17 EST 2008


I too am torn between usability and consistency; I certainly
see both sides of the issue. (I agree onInt or withInt don't
seem to fit, either.)

Just to get a high level view for the Ops.* API, one can see the layout at
 
  http://spreadsheets.google.com/ccc?key=pAoqbvjWjniKlWCMhVnW-ZA&hl=en

There, I highlighted the names which do not follow the pattern.

A table such as this (other layouts may be better) may be a nice addition
to the Javadoc. (For compactness, I left off the Ops. prefix.)

> Date: Tue, 15 Jan 2008 08:12:10 -0800
> From: "Joshua Bloch" <josh at bloch.us>
> 
> Gregg,
> 
> Hmmm... the onInt and withInt don't really feel right to me.  If people
> don't like intOp (or intFn), then I think we should go with David's
> inclination (intToInt).
> 
>           Josh

-- 
David J. Biesack     SAS Institute Inc.
(919) 531-7771       SAS Campus Drive
http://www.sas.com   Cary, NC 27513



More information about the Concurrency-interest mailing list