[concurrency-interest] Ops type names
josh at bloch.us
Tue Jan 15 15:52:25 EST 2008
Thanks. I agree that such a table would look nice in the JavaDoc. And just
so that others beside Doug and I way in on this, does anyone else have a
preference among: Ops, Op, Fns, Fn?
On Jan 15, 2008 12:38 PM, David J. Biesack <David.Biesack at sas.com> wrote:
> I too am torn between usability and consistency; I certainly
> see both sides of the issue. (I agree onInt or withInt don't
> seem to fit, either.)
> Just to get a high level view for the Ops.* API, one can see the layout at
> There, I highlighted the names which do not follow the pattern.
> A table such as this (other layouts may be better) may be a nice addition
> to the Javadoc. (For compactness, I left off the Ops. prefix.)
> > Date: Tue, 15 Jan 2008 08:12:10 -0800
> > From: "Joshua Bloch" <josh at bloch.us>
> > Gregg,
> > Hmmm... the onInt and withInt don't really feel right to me. If people
> > don't like intOp (or intFn), then I think we should go with David's
> > inclination (intToInt).
> > Josh
> David J. Biesack SAS Institute Inc.
> (919) 531-7771 SAS Campus Drive
> http://www.sas.com Cary, NC 27513
> Concurrency-interest mailing list
> Concurrency-interest at altair.cs.oswego.edu
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Concurrency-interest