[concurrency-interest] Rename compoundOp -> compositeOp

Doug Lea dl at cs.oswego.edu
Mon Jan 28 20:36:56 EST 2008

David J. Biesack wrote:
> I did not see any feedback on this earlier suggestion. Perhaps it got lost in
> the "with"/fluent API discussion:
> Rename CommonOps.compoundOp as CommonOps.compositeOp as per the well-known
> Composite design pattern.

Thanks; Sorry not to mention that it still in the set of likely changes.
Rather than commit this or any other renamings or refactorings
as they come in  though, I think I'll give people a chance to keep sending
suggestions for a while (like maybe a week) off current versions
and then see how things settle.


More information about the Concurrency-interest mailing list