[concurrency-interest] jsr166y.forkjoin API comments

Doug Lea dl at cs.oswego.edu
Tue Jan 29 19:10:54 EST 2008


David J. Biesack wrote:

> I suggest the name ParallelIntRange -- that is, the class is not a loop, anymore than ParallelArray is.
> 

Yes; thanks!

> However, once you add things like filter and map, perhaps this
> becomes nothing more than ParallelIntSet (if indeed you have plans
> for that), 

Not so sure. The nice thing about ParallelIntRange
is that it is very lightweight -- you can afford to make one on the fly just
to hold range/executor params for a single loop. A full ParallelIntSet
would need to, at least sometimes, create an internal bit set array
covering the whole range. And I'm not sure there are enough applications
for this to outweigh the advantages of the simple Range version.

-Doug



More information about the Concurrency-interest mailing list