[concurrency-interest] [Javamemorymodel-discussion] Fences.keepAlive

Doug Lea dl at cs.oswego.edu
Wed Jan 21 12:50:04 EST 2009

Shaffer, Darron wrote:
> keepAliveUntilThisPoint()?

or, to eliminate any sense that it is imperative,
I would like best the more declarative/assertional
except that it clashes with default-naming scheme that
would imply this is an accessor method (like Thread.isAlive).
Which might win terms of not mis-implying anything.

Keep 'em coming. Choosing good names is a game where the
ideas of potential users are usually better than those
of the implementors/designers.


More information about the Concurrency-interest mailing list