[concurrency-interest] Fwd: [Javamemorymodel-discussion] Fences.keepAlive
kschneider at gmail.com
Wed Jan 21 13:29:19 EST 2009
Sorry, replied to Doug only...
---------- Forwarded message ----------
From: Kris Schneider <kschneider at gmail.com>
Date: Jan 21, 2009 1:27 PM
Subject: Re: [Javamemorymodel-discussion] [concurrency-interest]
To: Doug Lea <dl at cs.oswego.edu>
On 1/21/09, Doug Lea <dl at cs.oswego.edu> wrote:
> Shaffer, Darron wrote:
> > keepAliveUntilThisPoint()?
> or, to eliminate any sense that it is imperative,
> I would like best the more declarative/assertional
> except that it clashes with default-naming scheme that
> would imply this is an accessor method (like Thread.isAlive).
> Which might win terms of not mis-implying anything.
> Keep 'em coming. Choosing good names is a game where the
> ideas of potential users are usually better than those
> of the implementors/designers.
How about some form of "ensure", like ref.ensureAlive()? There's
already some precedent with methods like ArrayList.ensureCapacity,
which makes no promises about what happens to the list's capacity at
any point in the future.
Otherwise, the discussion makes me think of verbs like "maintain", so
synonyms would be: "perpetuate", "prolong", "retain", "sustain",
"affirm", or some such...
Kris Schneider <mailto:kschneider at gmail.com>
More information about the Concurrency-interest