[concurrency-interest] Fence API

Doug Lea dl at cs.oswego.edu
Tue Jan 27 07:23:51 EST 2009

Walking through discussions of the name for the method initially
listed as "keepAlive", I'm giving one more shot to a concrete
proposal before resorting to a poll/vote.

The name "reachabilityFence" has a few virtues:
   * mentions reachability vs aliveness
   * "fence" implies the "here"-ness that was missing in other names
   * is of a similar form as other fences, so the spec can phrased
     in a similar way.
Probably the main disadvantage is that it is more awkward-sounding
that some other suggestions.

An updated draft with this wording is at

Please take a look. If there are more than a few complaints or
alternative suggestions, we'll do a poll.


More information about the Concurrency-interest mailing list