[concurrency-interest] RFR: 8065804: JEP 171: Clarifications/corrections for fence intrinsics

Martin Buchholz martinrb at google.com
Wed Dec 10 22:07:52 EST 2014


On Wed, Dec 10, 2014 at 4:52 PM, David Holmes <david.holmes at oracle.com> wrote:

> For the email record, as I have written in the bug report, I think the
> "correction" of the semantics for storeFence have resulted in problematic
> naming where storeFence and loadFence have opposite directionality
> constraints but the names suggest the same directionality constraints. Had
> the original API suggested these names with the revised semantics I would
> have argued against them. This area is confusing enough without adding to
> that confusion with names that don't suggest the action.

I also dislike the names of the "atomic" methods in Unsafe and would
like to align them as much as possible with C/C++ 11 atomics
nomenclature.


More information about the Concurrency-interest mailing list